Can MCU10.4 recover a bricked OpenSDA Freedom Board?

Ok, this one might not work for everyone. And maybe I’m seeing a ghost. But a nice and real one, at least for me :-). It seems that with the new CodeWarrior for MCU10.4 installation I was able to recover a bricked OpenSDA FRDM-KL25Z board 😯

Recovered OpenSDA Board

Recovered OpenSDA Board

Bricked OpenSDA

Here is what I had back in February this year: in my class students receive a FRDM-KL25Z board for the class room projects. As the boards come with the OpenSDA MSD (Mass Storage Device) Bootloader factory installed, they had to install the DEBUG-APP_Pemicro_v102.SDA application to debug it with CodeWarrior. That worked fine for everyone. Except for one student: that one board responded with an error code flashing on the red OpenSDA LED on the board, indicating that the DEBUG-APP programmign failed. So the board refused to program anything different from what was present on the OpenSDA K20.

❓ We really don’t know how we ended up in this situation. The student machine was a normal Windows machine, and it worked fine with another board. I was suspecting that the board got programmed with a wrong file, not sure. But in any case, the board should not get bricked.

I tried to program the board with my machine (Windows7 64bit), and same thing: that OpenSDA was stuck. Not a big deal given the low price of the board. But that was nagging on me. So I have put a sticker ‘only MSD’ on that board.

Trying to Recover

Over the next weeks, I had that board on my desk, and I tried occasional tests to recover it. The KL25Z was working fine, and I was able to debug it with the 10 pin SWD header I have put on it. I added jumpers to disconnect or un-power the OpenSDA chip: it did not  help. Well, I was still able to use that board, but not debugging with OpenSDA. Kind of non-ideal, but hey, I still can use it with the Multilink or USBDM ;-).

FRDM-KL25Z Board Modifications

FRDM-KL25Z Board Modifications

I was hoping that the new OpenSDA firmware released by P&E from 17-April-2013 could help: nope 😦

Then I tried to program it with the USBDM OpenSDA firmware. Same thing: failed 😦

CodeWarrior for MCU10.4

When I installed MCU10.4, I noticed that it must have installed new OpenSDA USB drivers, as boards re-enumerated again. Same thing for my ‘only MSD’ board: new drivers enumerated. That let me think “hey, let’s try that OpenSDA thing again” with it. So I entered BOOTLOADER mode, copied the DEBUG-APP_Pemicro_v106.SDA from the 17-April-2013 release, and ………………… : No error LED blinking!

And indeed, the V1.06 is loaded properly, and I can debug the board with OpenSDA:

Unblocked Board with PEMicro Debug App V1.06

Unblocked Board with PEMicro Debug App V1.06

It works with the V1.02 back from Feburary too:

Installed Debug Application V1.02

Installed Debug Application V1.02

And now USBDM firmware works on it too:

Loaded USBDM Firmware

Loaded USBDM Firmware

❗ The USBDM firmware does not properly report through the hardware information page, as there is no public information available, how that OpenSDA API works. But if it reports like above, I know USBDM is on it 🙂

Summary

Not sure if this applies to other boards, but if you have such an issue with the OpenSDA on the Freedom board, you might give it a try: Install CodeWarrior MCU10.4 with new drivers and see if it unlocks your board too. It did for mine :-). Somehow…

❗ I have not managed yet to get USBDM working with CodeWarrior for MCU10.4 (yet). Working on it…. But it works with the earlier CodeWarrior version for my recovered board.

Happy Unlocking 🙂

Advertisements

6 thoughts on “Can MCU10.4 recover a bricked OpenSDA Freedom Board?

  1. Pingback: Bricking and Recovering FRDM-KL25Z Boards: Reset, SWD Clock and Low Power | MCU on Eclipse

  2. Hi Erich I tried to update the bootloader in my Freedom and failed, now the laststat.txt file allways show “Programing…” and don’t take nothing else, I think I flashed the MSD_DEBUG_APP for the KL25Z before to update the bootloader and this cause damage, also the red LED in the board is allways on 😦

    Like

    • Hi Carlos,
      if you plug in the board with the reset button pressed, does it come up with the Bootloader?
      Having the MSD_DEBUG_APP on it before updating the bootloader should not be a problem.

      Like

      • Yes it come in bootloader mode but don’t flash anything you copy to the bootloader and the laststat.txt file in the bootloader always say “Programing…” i have a Multilink but i don’t find a way to flash the K20 micro with the sda file with it, can you give me any help??

        Like

        • Hi Carlos,
          you cannot program the K20 with a JTAG programmer: the K20 is protected and secured, so you cannot change it :-(.
          What operating system are you using? Windows 8? There is an issue with Windows 8.1 and OpenSDA, see one of my most recent posts.
          How do you copy the file to the bootloader? You cannot directly copy it from a .zip file: you need to extract the file first to your hard disk.
          And do not use any explorer extenstions. Try using the DOS Shell copy command instead.
          I hope this helps.

          Like

        • Hi Erich, I have Windows 8.1 in my laptop. I tried to update the openSDA in my desktop with Windows 8.0 and all work perfect! You were right! I also tried another Freedom board that have a damaged micro (I lend it 😦 ) and it did the same in W8.1 but the openSDA works in W8.0 I will use this one as a programmer with USBDM.

          Like

What do you think?

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s